ThingHttp Get Trouble | ThingSpeak Apps | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
ThingHttp Get Trouble
No permission to create posts
June 13, 2018
1:46 pm
Avatar
codenascher
New Member
Members
Forum Posts: 3
Member Since:
June 13, 2018
sp_UserOfflineSmall Offline

I'm using Matlab to compare Data from two channels. On certain Conditions Data is written to an channel which in turn triggers react to start thinghttp.
ThingHttp is supposed to send a simple get request to an url. The get request triggers a script on the server it is send to. Everything else is working. I simply need ThingHttp to send
this get request. No need to handle any return. Simply putting the url in my browser works so the script and server are all right. Yet it does not work. In ThingHttp I only gave an url, set input to get and http type to 1.1.
Can anyone help?

June 13, 2018
4:25 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 410
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

When you edit the request, you can see another request to trigger the ThingHTTP on the right hand side help pane. If you copy this into your browser, does it trigger the URL you desired? hat is the response from your browser to the trigger request?

In the react, there is a table that indicates when it was last run. Is your react running as you expect?

June 13, 2018
5:38 pm
Avatar
codenascher
New Member
Members
Forum Posts: 3
Member Since:
June 13, 2018
sp_UserOfflineSmall Offline

Okay, I found the problem. I tried to use placeholders like %%trigger%% in the url, thinking thinghttp would replace them with the actual values for me.

June 13, 2018
9:43 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 410
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

Sorry that was confusing. Thanks for posting the solution. If you read the doc, can you answer the survey feedback on the page where you saw replacement keys? That would really help us improve it.

June 14, 2018
2:19 am
Avatar
codenascher
New Member
Members
Forum Posts: 3
Member Since:
June 13, 2018
sp_UserOfflineSmall Offline

I will, thanks for the help.

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online:
27 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 261

Vinod: 196

piajola: 85

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 5703

Moderators: 0

Admins: 2

Forum Stats:

Groups: 4

Forums: 17

Topics: 1313

Posts: 4565

Newest Members:

KeslarAboth, EnigmBioge, debbiepe18, MatthewmUb, cathrynww1, Slark

Administrators: Hans: 387, lee: 457