Scheduled recurring timecontrol app is not fired/started. | ThingSpeak Apps | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Scheduled recurring timecontrol app is not fired/started.
No permission to create posts
January 4, 2018
6:49 am
Avatar
richlock
New Member
Members
Forum Posts: 2
Member Since:
January 4, 2018
sp_UserOfflineSmall Offline

Hi,I have several recurring timeControl app. What I have experienced that some of them usually is not started. Sometimes it is started, but it is random how it behaves. Those timers have actions interacting with talkback. Timers are recurring types, week based and should run every workdays at specified time.

For example the timer (29180)is scheduled but that scheduled date is passed, so somehow skipped.

Last Run: 2018-01-02 8:04 pm, Run At: 2018-01-03 8:00 pm

 

Timer:(29186)

Last Run:                                Run At: 2018-01-04 5:00 am

Current time is Jan-04-2018 12:20:00 PM CET.

 

Have you noticed similar problem or is it isolated just for me? Can someone check the log what the cause is of not starting the sheduled timers? I can provide the problematic timer IDs to check it: 29180 and 29186

Thanks:Richlock

January 4, 2018
7:04 pm
Avatar
Vinod

MathWorks
Members
Forum Posts: 327
Member Since:
May 1, 2016
sp_UserOfflineSmall Offline

I'm not sure I have correctly understood your problem, so please correct me if I got it wrong.

You have several TimeControls set to execute on a daily schedule. Sometimes of them execute on schedule, while others do not. You're trying to troubleshoot this. correct?

Information that would be helpful:

   What apps are tied to your TimeControl?

   How is the TimeControl interacting with TalkBack? 

Also, stepping back from the immediate issue you are trying to diagnose, can you provide more information describing your project so I can suggest something knowing about the application?

January 5, 2018
3:34 am
Avatar
richlock
New Member
Members
Forum Posts: 2
Member Since:
January 4, 2018
sp_UserOfflineSmall Offline

I attached picture when the TimeControl did not run. It can be noticed that the column "Last Run" did not refreshed after the prediefined time elapsed.
Nor my relay, controlled by talkback, switched on or off. The talkback functionality is working as I can trigger it manually from postman or curl and my device act on it.

This relay is for switching the heating. I try to replace my wall mounted programmable thermostat to have remote control possibilities and have original time control.

timecontrolImage Enlarger

I attached what is the detail one of my TimeControl settings.

TimeControl EditImage Enlarger

 

To overcome the issue, I edit the faulty timeControl (did not change anything) and save it. This way it is re-registered. Then I hope it will fired correctly next time.
The last day it was OK, so the problem may be gone. But for me this TimeControl app is not so reliable.

July 2, 2018
10:05 am
Avatar
Polaris82
New Member
Members
Forum Posts: 3
Member Since:
July 2, 2018
sp_UserOfflineSmall Offline

I've the same problem, did you solve?

July 2, 2018
4:17 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 771
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

Polaris82:
Can you share the settings for your TimeControl?

June 10, 2019
1:03 pm
Avatar
SuperFly
New Member
Members
Forum Posts: 2
Member Since:
June 10, 2019
sp_UserOfflineSmall Offline

I am experiencing a similar problem with timecontrol not running at scheduled times. It was functioning correctly until two days ago. It is not functioning for one time or recurring schedules. I have been using it to run Matlab Analysis scripts which do compile and function correctly when I run them manually.

June 10, 2019
2:30 pm
Avatar
Vinod

MathWorks
Members
Forum Posts: 327
Member Since:
May 1, 2016
sp_UserOfflineSmall Offline

@SuperFly I just set up a timecontrol that executes MATLAB code and it ran just fine. Can you provide any more detail about your timecontrol -- perhaps the name of the name of the MATLAB analysis it is tied to?

June 10, 2019
5:08 pm
Avatar
SuperFly
New Member
Members
Forum Posts: 2
Member Since:
June 10, 2019
sp_UserOfflineSmall Offline

I just ran it again and it executed, so I'm not certain what the problem was.

https://drive.google.com/file/d/1QN80JLq__1iin-xwveLl9Ftnie5yrJ0h/view?usp=sharing

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
20 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

Hema, askask, Rakwireless, budiardi basuki, oliver009, shelby1234

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457