What happened after your update? Charts? | ThingSpeak API | Forum

The ThingSpeak community site has been upgraded to a new site. This site is currently in read-only mode. You can ask questions or post and read discussions on the new site.
Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
What happened after your update? Charts?
No permission to create posts
February 1, 2013
3:46 am
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Hi Guys,

after your new update the charts are getting smaller when next datapoint arrives. What happened? There are "print the chart" and "export" icons on all charts, thats great, but displaying is not ok!

 

Thanks!

February 2, 2013
3:41 pm
Avatar
Hans
Natick, MA

Admin
Forum Posts: 411
Member Since:
January 18, 2011
sp_UserOfflineSmall Offline

Thanks for letting us know about the dynamic chart issues. We have discovered a bug in the chart library and will have a fix soon.

February 3, 2013
2:36 am
Avatar
CorBee
Netherlands

Gold
Members
Forum Posts: 37
Member Since:
December 10, 2012
sp_UserOfflineSmall Offline

Hi,

 

Many of the default graph options suddenly seem to be working less or not at all. When I for instance set the days option to 1 (nice addition !) and leave the results part empty I do get the data of the last day. If I however want to see the same data using an average, median or sum for each hour I only get one datapoint in the graph. For a oneday graph this is off course not an issue. But when I want to look at a longer dataspan and use for instance the 1440-average this would give me a nice graph that shows daily average electricity-usage. Unfortunately that type of graph seems to be non-functional currently.

 

kind regards

CorBee

February 5, 2013
7:43 am
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Thanks Hans,

please let us know, If you managed to fix the bug!

At this moment it seems the dynamic functions is not working,in private and public view I can see only the datapoint in every half an hour. Before this it was working like let's say every half an hour, and when opening the http page new datapoints came when they have to ( let's say in arduino sketch in every 2 minutes for example ).

And there is no time values on timeline. 

 

Best regards,

 

Pierre

February 6, 2013
3:59 am
Avatar
Hans
Natick, MA

Admin
Forum Posts: 411
Member Since:
January 18, 2011
sp_UserOfflineSmall Offline

Pierre,

Can you let me know if the issue is still the same? We made some changes to when dynamic charts get initiated and this may be the cause. Let me know if you see something else that you do not expect.

Thanks,

Hans

February 6, 2013
7:49 am
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Hi Hans,

 

It seems that chart are not refreshing. (Dynamic function is lost). Maybe other users should check this too.

There is too much space on the left side of the chart (Internet explorer) since you made changes.

Thanks!

 

Pierre

February 6, 2013
10:44 am
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Update: in your homepage ( main) light level is updating dynamically, but there is too much space on the left side of the graph.

On my channel (3426): no dynamic update, and only can see datapoints from every 30 minutes. That's totally different than before. It is the same in public and private view too... 

February 6, 2013
2:34 pm
Avatar
akinsgre

Silver
Members
Forum Posts: 9
Member Since:
May 6, 2012
sp_UserOfflineSmall Offline

Hi Pierre

 

1)  I'm not seeing the "too much space on the left side" problem.  So you mean that the inside of the chart area isn't populated with data, or that the chart doesn't take up as much space on the homepage? 

 

2)  What selections have you made on chart options?

February 7, 2013
3:19 am
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Hi,

1. Yes, I mean the chart doesn't take up much space as It was before. On Y axis my chart called Temperature celsius, and beside the Y axis name it has more space.

2.Setting for the charts:

type: line

Dynamic: true

Results : 2000

Timescale : 30

With this settings it was fine before and it was dynamic…Because of dynamic functions for me Thingspeak was(is) the best! Hope it will be fixedConfused

***

Update: removed the timescale 30 and datapoint are arriving. ( before this it was working with timescale 30 like: in the past datapoint were in every 30 minutes, and at the point of opening the page datapoints came in every X minutes, what the hardware did…)

If you set a Timescale value, the graph lost its dynamic option, next point will be on the grahps just after refreshing the browser

Space problem at Y axis is still alive.

February 7, 2013
8:39 am
Avatar
akinsgre

Silver
Members
Forum Posts: 9
Member Since:
May 6, 2012
sp_UserOfflineSmall Offline

Thanks Pierre. 

 

You can blame me for dropping the Dynamic when any of the "Timeslice" functions are set (ie., Timescale, avg, median, etc..).

 

I thought if a user was looking for accumulated values, then the dynamic feature isn't useful (because of the delay waiting for accumulated values).

 

The way it worked before was slightly broken.  A chart would be initially populated with averaged values, for example.  But as dynamic updates came in, they would be raw data points without the average applied.

 

Give me some feedback.  I'd love to make that more useful to you and all our users.

 

Secondly, regarding the chart space.  I'm still not seeing that; maybe I don't remember the way it was before the update.  Is there any chance you have some screenshots from before that you could share with me?  If not, I'll try to put up an old version on my dev environment to compare.

 

Thanks for your input.  It's great to hear from active users.

 

Greg

February 7, 2013
10:19 am
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Greg,

I'm really happy that there are peoples who take care about the functions! Laugh

So the way it was worked was really great for me, I don't know about other users. That was nice past values until displaying time and dynamic after displaying time even if it was brokenConfused

About the spaces:

this is with timescale option,no dynamic

Image Enlarger

and this is dynamic:

Image Enlarger

 

Dynamic has more bigger space beside Y axis.

because of spaces, qraphs aren't look so niceCry

Unfortunately I do not have picture how looked like before,but I hope you'll see the problem.
Before your updates it was heaven

February 7, 2013
2:03 pm
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Important update: The problem what can be seen on the printscreen appears only if using IE8. With Firefox and Chrome it is working perfectly! I have realised it, because of using different PC-s and laptops.( regarding the space beside Y axis )

February 8, 2013
10:44 am
Avatar
akinsgre

Silver
Members
Forum Posts: 9
Member Since:
May 6, 2012
sp_UserOfflineSmall Offline

Thanks very much Pierre

 

We tend to not use IE much around here.. so that slipped through the cracks.  Thanks for the heads up.  I'm a Mac user.. so I guess I'll have to fire up a VM and take a look at that.

 

Regarding the updates of Dynamic, we'll see if we can get something back into an upcoming release to deal with that.  

 

Thanks for your time and patience!

February 12, 2013
3:56 am
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Thanks for the answer, I'm waiting to hear about upcoming release! You are great guys, just go on!:)

February 13, 2013
1:42 am
Avatar
vespapierre

Gold
Members
Forum Posts: 63
Member Since:
February 1, 2013
sp_UserOfflineSmall Offline

Just one more important notice: after your last release update browser needs more memory and cpu to draw the graph!so on the same machine the same graph is slower to daw.

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
33 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

Advantagetreeexperts, laundrydaddyuk, techhhelp5, ken, tran, huldacormier

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457