Website iframe in my website only update when I am logged into Thingspeak ... | ThingSpeak API | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Website iframe in my website only update when I am logged into Thingspeak ...
No permission to create posts
October 28, 2018
12:12 am
Avatar
Smitty
New Member
Members
Forum Posts: 4
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

I have multiple iframes in my website with the api and channel setup correctly that only update when I am logged into thingspeak with my browser. Anyone else had this situation?.

October 30, 2018
1:57 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 477
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

That is expected behavior for private channels. Are the embedded iframes for private channels or public channels?

If you want to private channels when logged out, you can embed the read api key in the iframe text. Keep in mind you will be sharing your read api key with whomever sees the page.

...src=https://thingspeak.com/channels......&api_key=YOUR CHANNEL READ API KEY

November 2, 2018
11:05 pm
Avatar
Smitty
New Member
Members
Forum Posts: 4
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Thanks, yes the api key is already there ..... everything is setup the way it should be .... according to numerous posts about this in this forum, however the website does not load the iframe ... below is a line of the iframe code..

iframe width="450" height="260" style="border: 1px solid #cccccc;" src="https://thingspeak.com/channels/###/charts/4?bgcolor=%23ffffff&color=%230099cc&dynamic=true&timescale=15&api_key=:#######&title=%2B150mm+Air&type=spline&xaxis=Date%2FTime&yaxis=Temp+%C2%B0C">

The hashs have the appropriately correct channel and read api key.
If the computer I am accessing the webpage from has not logged into thingspeak, then the iframe reports invalid channel ...
Very strange behaviour. Has anyone struck this before. Cool

November 5, 2018
1:57 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 477
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

Is the colon before the API key a typo? That tripped me up when I tried to copy and paste your code.
I still see the same behavior, the frames display even when I am not logged in. (assuming I remove the colon and include the read API key)

November 8, 2018
12:52 pm
Avatar
Smitty
New Member
Members
Forum Posts: 4
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

cstapels said

Is the colon before the API key a typo? That tripped me up when I tried to copy and paste your code.
I still see the same behavior, the frames display even when I am not logged in. (assuming I remove the colon and include the read API key)  

We have a saying in New Zealand. "Good on ya mate ... " Confused biggest duh moment I have had for a while. Wonder why the colon was slipping in there, might be part of the bluefish editors ways of doing things. Thanks heaps .... maybe push this up the search engine a bit, I found a couple of others asking the same question without any answers.

The web page they are in is http://smitty.co.nz/succulents.html no biggy just a play page where the sensors in my garden report air and soil temps etc.

November 8, 2018
3:57 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 477
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

Glad we found the solution. Ill search the forum for other instances of sneaky colons. 😐
Nice display by the way, your dashboard looks really nice (though it looks to be a chilly 13 C or so there). Thanks for sharing!

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online:
40 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

JerilynDernnida, JaketripDernnida, KenterDernnida, AlisaMiz, AriurinDernnida, KabinaDernnida

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457