Unable to trigger email using IFTTT | ThingSpeak API | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Unable to trigger email using IFTTT
No permission to create posts
July 10, 2018
5:14 am
Avatar
mnaveed1

Gold
Members
Forum Posts: 25
Member Since:
June 15, 2018
sp_UserOfflineSmall Offline

Hello,
I am following this tutorial https://www.mathworks.com/help/thingspeak/analyze-channel-data-to-send-email-notification-from-ifttt.html

I have my own matlab anaylsis. But I am not getting any emails. I found out that my applet failed to work. Can anyone explain what's the issue and how to fix it ?

July 10, 2018
9:40 am
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 410
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

There are several moving parts in this example.
When you paste the trigger url from IFTTT in your browser, do you get an email? If not, then you have configured IFTTT incorrectly. There is also a test button for the IFTTT applets. It sounds like this is the problem. I suggest deleting the applet and starting over, trying to follow the steps as closely as you can.

When you run the MATLAB analysis, do you get any errors? Did you modify the example or are you using data from the existing moisture channel? The plant monitor in my office recently needed a reset and I missed some data from June 20-July 5 or so. The email should still wok however, since it is supposed to send regardless of the water state.

Let us know what you are seeing.

I am glad to hear you are trying it out. Once you get it working, if you get a chance, can you respond to the survey at the bottom of the page with suggestions on improvement?

July 15, 2018
8:15 am
Avatar
mnaveed1

Gold
Members
Forum Posts: 25
Member Since:
June 15, 2018
sp_UserOfflineSmall Offline

Hello,
Thanks for your message.
When I paste URL in my browser I get this message "Congratulations! You've fired the tempandhum event". However, I don't get any email. There are no errors in my Matlab analysis. I followed exact same steps as shown in the tutorial. However, in step 7 I got confused. Therefore, I wrote exactly the same subject and body of the email as shown in the tutorial. Any idea whats wrong ?

July 16, 2018
11:05 am
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 410
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

I would guess that your email client is filtering the IFTTT emails into your junk email. Do you receive any other emails from IFTTT? Perhaps have a look at your email filters.
Step 7 is where you configure the content of the email, but you cannot change the send address. The image in step 7 does not include Value2, but you should still get a message from IFTTT. If you still don't see it in your junk email, you might try configuring with a different email address if you have one.

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online: ziplock9000
29 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 261

Vinod: 196

piajola: 85

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 5703

Moderators: 0

Admins: 2

Forum Stats:

Groups: 4

Forums: 17

Topics: 1313

Posts: 4565

Newest Members:

EnigmBioge, debbiepe18, MatthewmUb, cathrynww1, Slark, inads11

Administrators: Hans: 387, lee: 457