Failed to load resource: the server responded with a status of 422 (Unprocessable Entity) | ThingSpeak API | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Failed to load resource: the server responded with a status of 422 (Unprocessable Entity)
No permission to create posts
April 14, 2019
1:22 am
Avatar
turgo

Gold
Members
Forum Posts: 77
Member Since:
June 16, 2013
sp_UserOfflineSmall Offline

I'm getting a new error this week when I do "https://thingspeak.com/channels/xxxxxx/feed/last.json?callback=jQuery..."
Has something changed? I can see this data in my private view graphs on thingspeak.com.

April 14, 2019
8:18 pm
Avatar
Vinod

MathWorks
Members
Forum Posts: 306
Member Since:
May 1, 2016
sp_UserOfflineSmall Offline

An upgrade on our end to the frameworks we use seems to have resulted in the framework sending 422's for cross-site requests. We're looking into this with a goal to resolve these with no changes required on your end. Stay tuned!

April 15, 2019
10:26 am
Avatar
turgo

Gold
Members
Forum Posts: 77
Member Since:
June 16, 2013
sp_UserOfflineSmall Offline

Thankyou. It's nice to know the problem isn't mine.

April 15, 2019
11:54 am
Avatar
Hgestel
New Member
Members
Forum Posts: 2
Member Since:
December 29, 2017
sp_UserOfflineSmall Offline

I am facing the same problem since last friday.
Spent a lot of time in whats happening, did I do something wrong or is something on my site corrupted.

So I'am glad it is aknowleged , something is chaSmilenged at thingspeak site.

When can we expect a solution?

rgds
Henry

April 23, 2019
10:07 am
Avatar
turgo

Gold
Members
Forum Posts: 77
Member Since:
June 16, 2013
sp_UserOfflineSmall Offline

What's the progress on this 422 error?

April 23, 2019
11:49 am
Avatar
Vinod

MathWorks
Members
Forum Posts: 306
Member Since:
May 1, 2016
sp_UserOfflineSmall Offline
April 23, 2019
1:48 pm
Avatar
turgo

Gold
Members
Forum Posts: 77
Member Since:
June 16, 2013
sp_UserOfflineSmall Offline

I removed the callback keyword, and now have the error:
Failed to load resource: Cross-origin redirection to https://thingspeak.com/channels/xxxx/feed/last.json?api_key=xxxxxxxxxxxxxxxx denied by Cross-Origin Resource Sharing policy: Origin http://myplace.frontier.com is not allowed by Access-Control-Allow-Origin.
What next?

April 23, 2019
3:45 pm
Avatar
Vinod

MathWorks
Members
Forum Posts: 306
Member Since:
May 1, 2016
sp_UserOfflineSmall Offline

Try changing that to https://api.thingspeak.com/channels/xxxx/feed/last.json?api_key=xxxxxxxxxxxxxxxx

Note the insertion of 'api' in the domain name.

April 23, 2019
7:14 pm
Avatar
turgo

Gold
Members
Forum Posts: 77
Member Since:
June 16, 2013
sp_UserOfflineSmall Offline

These small details are hard to catch. I was successful when I changed "www" to "api". Thanks for the help.

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
28 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

aaceitunog01, AlinaCutle, MARTO, simplicity1, jango6954, LDN001

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457