Channel cannot plot data from esp32 | ThingSpeak API | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Channel cannot plot data from esp32
No permission to create posts
August 23, 2019
1:21 am
Avatar
jefflam1994
New Member
Members
Forum Posts: 1
Member Since:
August 23, 2019
sp_UserOfflineSmall Offline

Hi, i have followed the tutorial with same arduino code but using esp32 wifi module
I saw the result from serial monitor,changed to my api channel, successfully connect the wifi router and show the data in serial
But I cannot see the data in the thingspeak api channel, thank you.

https://iotdesignpro.com/projects/how-to-send-data-to-thingspeak-cloud-using-esp32

August 23, 2019
10:53 am
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 863
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

Are you able to see data that you post using a REST call in your browser window? On the API keys tab of your channel view, the first command on the right hand side in the help will show you the format. It should be something like
https://api.thingspeak.com/update?api_key=XXXXXXXXXXXXXXXX&field1=10 but with your API key in it. Try that command in the browser and let us know if you see data in the channel.

July 23, 2020
10:34 pm
Avatar
Anushree
New Member
Members
Forum Posts: 2
Member Since:
July 23, 2020
sp_UserOfflineSmall Offline

Hello,
Even I am having the same problem as jefflam1994. Could someone tell me what the problem might be and how can I solve it?

August 6, 2020
10:16 am
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 863
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

Are you able to see data that you post using a REST call in your browser window? On the API keys tab of your channel view, the first command on the right hand side in the help will show you the format. It should be something like
https://api.thingspeak.com/update?api_key=XXXXXXXXXXXXXXXX&field1=10 but with your API key in it. Try that command in the browser and let us know if you see data in the channel.

FYI, MATLAB answers is the preferred location for ThingSpeak Community support.

October 10, 2020
2:50 am
Avatar
mahe24
New Member
Members
Forum Posts: 2
Member Since:
October 10, 2020
sp_UserOfflineSmall Offline

Hi I am having the same problem, Not able see the enteries before, but i use this link

https://api.thingspeak.com/update?api_key=XXXXXXXXXXXXXXXX&field1=10

I past the above link in my broswer then past APIKEY and refresh every 15 second i got some integer value, and then i visit my channel view the saw there is a Entries, can you please support me to clear this issue...

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
31 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

daner, Tito Silveira, HomeImprove123, Bryan, kenwood1701, dosh2684

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457