Cannot Add a TalkBack Command via HTTP POST | ThingSpeak API | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Cannot Add a TalkBack Command via HTTP POST
No permission to create posts
January 19, 2015
2:31 am
Avatar
waynebraganza

Silver
Members
Forum Posts: 6
Member Since:
January 19, 2015
sp_UserOfflineSmall Offline

need help with the add talkback command via http post feature.... im new but i was able to execute the next command via HTTP POST by typing
"https://api.thingspeak.com/talkbacks/1203/commands/execute?api_key=0OT6Y43XC6Y5YVJ9"
in my web browser...

similarly when i tried to add a command by typing
"https://api.thingspeak.com/talkbacks/1203/commands?api_key=0OT6Y43XC6Y5YVJ9&command_string=ON&position=1"
the command was just not getting added.... can any 1 please help....

n sorry if this post is in the wrong part of the forum.... its my first post in a forum.... will appreciate all the help.....
ps. i went through the talk back examples and was able to get the execute next command to work in a few mins.... but the add command part has been haunting me for hours..... i need to use HTTP POSTs in text only as the part of the project... not json and xml

January 19, 2015
10:03 am
Avatar
lee

Admin
Forum Posts: 457
Member Since:
March 14, 2011
sp_UserOfflineSmall Offline

Hi,

Executing a TalkBack command is done via HTTP GET or POST, and by typing it into your web browser you are doing an HTTP GET. Adding a command is only allowed via POST though, so typing it into your web browser won't work. To execute a POST you can use an HTML form submit, JavaScript, a browser extension, etc.

lee

January 20, 2015
1:26 am
Avatar
waynebraganza

Silver
Members
Forum Posts: 6
Member Since:
January 19, 2015
sp_UserOfflineSmall Offline

oh... .thanks alot man....... that helped... i found an extension for chrome n am able to add commands :) now all i got to do is implement this into an arduino with the esp8566 wifi module....

anyways thanks for d reply... im new to this stuff n ur reply fixed my problems.... :)

March 3, 2016
8:58 am
Avatar
Midoji
New Member
Members
Forum Posts: 1
Member Since:
March 3, 2016
sp_UserOfflineSmall Offline

Hello, what is your google chrome extension for my project ?

Or, do you know any good extension for add command from thingspeak please ? Thanks in advance everyone !

December 12, 2017
3:36 pm
Avatar
waynebraganza

Silver
Members
Forum Posts: 6
Member Since:
January 19, 2015
sp_UserOfflineSmall Offline

Midoji said
Hello, what is your google chrome extension for my project ?

Or, do you know any good extension for add command from thingspeak please ? Thanks in advance everyone !  

hi,

sorry for the really late reply, the extension that i used in chrome is "Chrome Poster"

best of luck with whatever you're doin

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online: Hans, agrisensezm
36 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 261

Vinod: 196

piajola: 85

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 5703

Moderators: 0

Admins: 2

Forum Stats:

Groups: 4

Forums: 17

Topics: 1313

Posts: 4565

Newest Members:

Archieter, JamesExedo, IrbosHich, brodi, kasko, franklin castro

Administrators: Hans: 387, lee: 457