Attaching JPEGS to a post - Seems to be blockage. | ThingSpeak API | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Attaching JPEGS to a post - Seems to be blockage.
No permission to create posts
January 28, 2019
1:24 am
Avatar
Timbergetter
NSW

Silver
Members
Forum Posts: 10
Member Since:
January 27, 2019
sp_UserOfflineSmall Offline

I am trying to upload a 49KB jpeg to illustrate a forum post. I am getting the error response:

Error 106 - Upload file size exceeds maximum allowed size.

49KB doesn’t seem all that huge.

January 28, 2019
8:20 am
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 691
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

Ill look into it, thanks for the info. Can you let me know your browser type when you get a chance?

January 28, 2019
5:21 pm
Avatar
Timbergetter
NSW

Silver
Members
Forum Posts: 10
Member Since:
January 27, 2019
sp_UserOfflineSmall Offline

I use Firefox Version 64.0, first offered to Release channel users on December 11, 2018 (Ubuntu 16.04)

January 28, 2019
5:53 pm
Avatar
Vinod

MathWorks
Members
Forum Posts: 305
Member Since:
May 1, 2016
sp_UserOfflineSmall Offline

Is it possible to post the image on a service like imgur and link to it in your post?

January 28, 2019
9:56 pm
Avatar
Timbergetter
NSW

Silver
Members
Forum Posts: 10
Member Since:
January 27, 2019
sp_UserOfflineSmall Offline

I just tried to upload using Chrome with same result.
What is the maximum image size?
Thanks for your suggestion Vinod. I don't currently use a hosting service, but I'l pursue that if I continue to have a problem.

January 29, 2019
6:01 pm
Avatar
Timbergetter
NSW

Silver
Members
Forum Posts: 10
Member Since:
January 27, 2019
sp_UserOfflineSmall Offline

Tried again with a Windows OS using Firefox 65.0 (64 bit), and still get Error 106 when trying to Upload.
My internet connection is over satellite, so could latency be an issue here?

January 29, 2019
6:14 pm
Avatar
Timbergetter
NSW

Silver
Members
Forum Posts: 10
Member Since:
January 27, 2019
sp_UserOfflineSmall Offline

No. It's not a satellite problem.
I just tried again through a terrestrial gateway (3G)
and same problem.

January 30, 2019
2:07 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 691
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

I just tried 63 kb and it failed. Ill see what might be done to increase the limit and let you know.

January 30, 2019
4:51 pm
Avatar
Timbergetter
NSW

Silver
Members
Forum Posts: 10
Member Since:
January 27, 2019
sp_UserOfflineSmall Offline

I've tried again, after shrinking the file size to 29KB and this has succeeded. As you can see from the result the resolution is barely acceptable and a slightly larger image size would be worthwhile in my opinion.

Data-Skip.jpgImage Enlarger

sp_PlupAttachments Attachments
January 31, 2019
10:50 am
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 691
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

I'm looking into the file size issue. Were you able to get an answer for the original problem you wanted to post about? Probably start is on another thread if you can please. You can use a REST call (https://www.mathworks.com/help/thingspeak/readdata.html) or the data export button to export recent data and post that. Its probably just about as helpful as the plots for looking for problems, unless you were using the chart settings.

January 31, 2019
4:42 pm
Avatar
Timbergetter
NSW

Silver
Members
Forum Posts: 10
Member Since:
January 27, 2019
sp_UserOfflineSmall Offline

Thank you cstapels for your response. I did start a new thread and attached the 29KB image which was satisfactory for that purpose. If you would like me to battle test a larger upload when you have adjusted things I am happy to do that, however I think you are on top of things in that you can replicate the issue with your 63KB failure.

June 7, 2019
2:06 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 691
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

We have increased the image size limit substantially. Thank you for your patience. Please let us know if you encounter further issues.

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
27 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

Sahil Nair, ahancity, samexpert, Senseworks, h-kasiri, kleifimmakly

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457