thingSpeakPlot error | MATLAB IoT Analytics | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
thingSpeakPlot error
No permission to create posts
September 13, 2018
10:38 pm
Avatar
beluga
New Member
Members
Forum Posts: 2
Member Since:
September 13, 2018
sp_UserOfflineSmall Offline

Sometime in the last few days a visualization that uses thingSpeakPlot has stopped working. The error is:

Error using thingSpeakPlot (line 59)
The following error occurred converting from datetime to double:
Undefined function 'double' for input arguments of type 'datetime'. To convert from datetimes to numeric, first subtract off a datetime origin, then convert to numeric using the
SECONDS, MINUTES, HOURS, DAYS, or YEARS functions.

The same code was previously working. I've created a very simple test that reproduces the problem (code below). Seems like something has changed in thingSpeakPlot ... help !

% dummy table data
Timestamps = datetime({'2015-12-18 08:03:05';'2015-12-18 10:03:17';'2015-12-18 12:03:13';'2015-12-18 13:07:23';'2015-12-18 14:45:51'});
Temp1 = [37.3; 39.1; 42.3; 38.9; 33.6];
Temp2 = [33.5; 33.7; 34.5; 35.7; 37.6];
Temp3 = [24.0; 28.1; 26.3; 27.3; 33.6];

% create timetable
TT = timetable(Timestamps,Temp1,Temp2,Temp3);

% Visualize Data
thingSpeakPlot(TT.Timestamps, TT.Variables);

September 14, 2018
2:15 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 477
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

I am able to reproduce this issue. We are working on a resolution and expect to implement it shortly.

September 14, 2018
3:30 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 477
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

The issue has been resolved. I no longer see the same error when I test the code you provided. Please let us know if you continue to see the issue. Be sure to refresh your browser before testing. Thank you for your help!

September 14, 2018
4:29 pm
Avatar
beluga
New Member
Members
Forum Posts: 2
Member Since:
September 13, 2018
sp_UserOfflineSmall Offline

Working perfectly again. Thanks for the quick response

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online:
34 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

AlisaMiz, AriurinDernnida, KabinaDernnida, lakishakm3, CoreenDernnida, yeseniarowe

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457