ThingSpeak Local Installation Admin login page | GitHub Installation | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
ThingSpeak Local Installation Admin login page
No permission to create posts
August 2, 2015
7:23 pm
Avatar
sanyaade
New Member
Members
Forum Posts: 3
Member Since:
August 2, 2015
sp_UserOfflineSmall Offline

Hello everyone,

I have setup ThingSpeak locally on an Ubuntu 15.05 server and I will like to access its admin page from: localhost:3000/admin/ but I have try all possible admin name still not being able to login into it.

I have follow instruction at: http://community.thingspeak.com/forum/thingspeak-api/retrieve-my-password/ and also: https://github.com/other/thingspeak#optional-admin-setup but good results.

I need help: How can I setup admin use (or super user or site administrator) for site administration?

Many thanks!

hear from you soon!

God blesses!!!

Best regards,
Sanyaade

August 3, 2015
9:20 am
Avatar
lee

Admin
Forum Posts: 457
Member Since:
March 14, 2011
sp_UserOfflineSmall Offline

Hi Sanyaade,

When you follow the instructions at https://github.com/other/thingspeak#optional-admin-setup , are there any errors after you create your AdminUser? Are you running the Rails console with the same environment as the server you're running?

lee

August 4, 2015
5:49 am
Avatar
sanyaade
New Member
Members
Forum Posts: 3
Member Since:
August 2, 2015
sp_UserOfflineSmall Offline

Hi Lee,
Many thanks for your reply and support!

1.) There were no errors adding email: and password but I was unable to add user name when I was creating the AdminUser as syntax for user: was rejected if I add it to it.

2.) Yes I was running the rails console on the same server I installed ThingSpeak.

Please help! I am very grateful for your reply!
Many thanks!

hear from you soon!

God blesses!!!

Best regards,
Sanyaade

August 4, 2015
6:21 am
Avatar
sanyaade
New Member
Members
Forum Posts: 3
Member Since:
August 2, 2015
sp_UserOfflineSmall Offline

Hi Lee,

I will be answering my own questions here again.
The Admin login is working. I dont know what I did that made it to work and I can now login into the Admin page. what I can remebered was that:

1.) Shutdown the rails running
2.) execute the command: rails console
3.) run: AdminUser.create!(email: 'myname@email.com', password: 'My_PASSWORD', password_confirmation: 'My_PASSWORD')

4.) Exit the rails console: exit
5.) run: rails server
6.) access the server at: localhost:3000/admin
7.) enter my email as login and my password ( created in step 3 above)

I was able to access the dashboard and navigate around it.

Lee many thanks for your support.

I think I need to learn Ruby and understand how rails works if I want to get the grip of ThingSpeak. Ruby, Erlang, Go are being used now in IoT platforms. Iwont have much problems with Java, C/C++, Lua or Python.

Lastly I noticed that ThingSpeak interface was based after ActiveAdmin. I follow it from your github.com. I will need to study it as well so that I can contribute to ThingSpeak.

Once again many thanks for your support. really appreciated!

hear from you soon!

God blesses!!!

Best regards,
Sanyaade

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
9 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

khanhNguyen_CT, susyburr, quijano__, meosuckhoe, briskpanda, Dejw0089

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457