rake db:create error | GitHub Installation | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
rake db:create error
No permission to create posts
April 6, 2014
11:12 pm
Avatar
simonvo
New Member
Members
Forum Posts: 4
Member Since:
April 6, 2014
sp_UserOfflineSmall Offline

hi,
I have problem with rake db:create
/usr/local/thingspeak# rake db:create
rake aborted!
database configuration does not specify adapter
/var/lib/gems/2.0.0/gems/activerecord-4.0.3/lib/active_record/connection_adapters/connection_specification.rb:52:in `resolve_hash_connection'
/var/lib/gems/2.0.0/gems/activerecord-4.0.3/lib/active_record/connection_adapters/connection_specification.rb:46:in `resolve_string_connection'
/var/lib/gems/2.0.0/gems/activerecord-4.0.3/lib/active_record/connection_adapters/connection_specification.rb:32:in `spec'
/var/lib/gems/2.0.0/gems/activerecord-4.0.3/lib/active_record/connection_handling.rb:39:in `establish_connection'
/var/lib/gems/2.0.0/gems/activerecord-4.0.3/lib/active_record/tasks/database_tasks.rb:89:in `create_current'
/var/lib/gems/2.0.0/gems/activerecord-4.0.3/lib/active_record/railties/databases.rake:20:in `block (2 levels) in '
Tasks: TOP => db:create
(See full trace by running task with --trace)
The previously steps are sucessfully, but i have got problem with this
Any advice , plz
Thanks
Simon Cry

April 6, 2014
11:13 pm
Avatar
simonvo
New Member
Members
Forum Posts: 4
Member Since:
April 6, 2014
sp_UserOfflineSmall Offline

here is my database configuration file:
# And be sure to use new-style password hashing:
# http://dev.mysql.com/doc/refman/5.0/en/old-client.html
production:
adapter: mysql2
encoding: utf8
host: localhost
reconnect: true
database: thingspeak
pool: 5
username: thingspeak
password: "password"

April 6, 2014
11:55 pm
Avatar
lee

Admin
Forum Posts: 457
Member Since:
March 14, 2011
sp_UserOfflineSmall Offline

Hi,

If you're only running the production server, you should migrate your database using:
RAILS_ENV=production rake db:migrate

lee

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
21 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

swatiiot, kalyanigaware16@gmail.com, Romi, Drakan01, majidkhan7, atharvganla

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457