Login problem | General | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Login problem
No permission to create posts
November 12, 2018
1:29 pm
Avatar
Llaves

Silver
Members
Forum Posts: 7
Member Since:
July 29, 2017
sp_UserOfflineSmall Offline

When I try to login to Thingspeak I enter my email address on the login screen, hit enter. The next screen has a box pre-filled with my user name, not my email, then a blank box for the password. But apparently the first box needs to contain my email address and is not editable. I'm using Firefox, tested in safe mode with all plug-ins disabled, no VPN. When I tried with Chrome, the first time I logged in the email box on the second page was blank, so I filled it in and was able to sign in. The next time I tried it was pre-filled, though unlike FF, it was filled correctly.

How do I fix the login page on Firefox?

November 12, 2018
5:33 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 861
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

In Firefox, select the 'open menu' hamburger icon in the upper right (see images) .
then select 'Options', then 'Privacy and Security', and finally 'Saved Logins'.
Edit the email, or password for 'login.mathworks.com' as desired.
Not sure the images are cropped right, please let me know if this helps.

firefox_fix1.pngImage Enlarger

firefox_fix2.pngImage Enlarger

sp_PlupAttachments Attachments
November 12, 2018
7:05 pm
Avatar
Llaves

Silver
Members
Forum Posts: 7
Member Since:
July 29, 2017
sp_UserOfflineSmall Offline

This is not a saved login issue. I use saved logins all the time with no problem. If you don't like the choice, you can just type over it. In this case, the value is being sent from the Thingspeak side of things and can't be edited.

November 12, 2018
7:25 pm
Avatar
Vinod

MathWorks
Members
Forum Posts: 339
Member Since:
May 1, 2016
sp_UserOfflineSmall Offline

Actually, this is a bug in Firefox, specifically its password manager. Try this:

1) Fill out the form in https://thingspeak.com/login and hit next
2) On the next page, right click on the element which has a username (instead of the email address that you typed up) and hit inspect element
3) Note that the value there is actually the email address you entered in in (1), however, what is displayed by Firefox is a saved login

What CStapels gave you is a workaround to the bug in Firefox where the saved login is replaced with the email address so that is what gets displayed and sent to the MathWorks servers when you hit the "Login" button.

This also explains why you do not see this problem in any other browser, except Firefox.

November 12, 2018
7:32 pm
Avatar
Llaves

Silver
Members
Forum Posts: 7
Member Since:
July 29, 2017
sp_UserOfflineSmall Offline

Editing the password in the manager screen didn't work, but deleting it did.
Thanks

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
21 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

briskpanda, Dejw0089, Yassine Ben Salah, anis, 43994554AKS, suda

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457