Has the behaviour of median=10 changed? | General | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Has the behaviour of median=10 changed?
No permission to create posts
March 12, 2014
6:56 am
Avatar
chrisjmears

Gold
Members
Forum Posts: 54
Member Since:
April 26, 2013
sp_UserOfflineSmall Offline

I noticed this last night. I assumed corrupt data so I cleared the channel but same again today

api.thingspeak.com/channels/5384/feed.csv?&days=1&median=10

gives the result:

created_at field1 field2 field3 field4 field5 field6 field7 field8
2014-03-12 10:20:00 UTC 2 60 0 1
2014-03-12 10:30:00 UTC 2 60 0 0
2014-03-12 10:40:00 UTC 2 60 0 0
2014-03-12 10:50:00 UTC 2 60 0 0

i.e field 1 & 2 which contain temperature data are blank

but when I do

api.thingspeak.com/channels/5384/feed.csv?&days=1

I get

created_at entry_id field1 field2 field3 field4 field5 field6 field7 field8
2014-03-12 10:22:49 UTC 1 3.5 4.5 2 5 60 0 1 0.0/0.0/28.0/40.0/ 570/1/v2.0rc32
2014-03-12 10:23:01 UTC 2 3.5 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:23:13 UTC 3 3.5 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:23:25 UTC 4 4 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:23:37 UTC 5 3.5 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:23:49 UTC 6 3.5 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:24:01 UTC 7 3.5 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:24:13 UTC 8 4 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:24:25 UTC 9 4 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:24:37 UTC 10 4 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:24:49 UTC 11 4 4.5 2 5 60 0 0 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:25:01 UTC 12 4 5 2 5 60 0 1 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32
2014-03-12 10:25:13 UTC 13 4 4.5 2 5 60 0 1 0.0/0.0/28.0/40.0/ 600/1/v2.0rc32

So there is data in field 1 and field 2. its just not being averaged!

March 12, 2014
5:46 pm
Avatar
lee

Admin
Forum Posts: 457
Member Since:
March 14, 2011
sp_UserOfflineSmall Offline

Hi,

Some of your feed entries have spaces before the numerical values, which is causing our system to interpret your data as strings rather than numbers. Please try changing your Channel updates so that they send "8.5" rather than " 8.5", for example.

lee

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
25 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

Team_mafia, icXu, emorphistechno, VTVMART, manimozhi, adamhebrew

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457