Problem uploading data from NodeMCU to the IoT ThingSpeak | ESP Wi-Fi | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Problem uploading data from NodeMCU to the IoT ThingSpeak
No permission to create posts
June 7, 2018
7:28 am
Avatar
victormh
New Member
Members
Forum Posts: 1
Member Since:
June 7, 2018
sp_UserOfflineSmall Offline

Hello, I am uploading data from NodeMCU to the IoT ThingSpeak platform and I have a problem that I do not know where it may come from.

When I upload data from my private Wi-Fi network, from home, I see them correctly and everything works fine. When I upload them from the university network, I do not see it in ThingSpeak. The same software and all the same in several examples. I only change the credentials of the wifi.

Does anyone have any idea what can happen ???

June 10, 2018
12:09 am
Avatar
rw950431

Top
Members
Forum Posts: 279
Member Since:
January 30, 2014
sp_UserOfflineSmall Offline

Are you able to update your Thingspeak channel using your browser on the University network? (see https://au.mathworks.com/help/thingspeak/writedata.html for format of URL).

Do you get any return code from the NodeMCU when you try to write? At what point does it fail? Are you able to read data from a channel?

It may be that your University requires you to use a proxy to access the internet.

It is unfortunate that Thingspeak does not have a diagnostic console where you can view the status of incoming requests.

June 11, 2019
2:56 pm
Avatar
marcos@agro.unlpam.edu.ar
New Member
Members
Forum Posts: 1
Member Since:
June 11, 2019
sp_UserOfflineSmall Offline

Hi, how i can connect an ESP8266 to api.thingspeak.com using Thingspeak library for Arduino?.
I'm behind a proxy without authentication.
Thanks.

June 12, 2019
1:50 pm
Avatar
cstapels
Moderator
Members


Moderators
Forum Posts: 771
Member Since:
March 7, 2017
sp_UserOfflineSmall Offline

What happens when you try to connect or post?

Forum Timezone: America/New_York

Most Users Ever Online: 166

Currently Online:
20 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 272

Vinod: 240

piajola: 95

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 8665

Moderators: 1

Admins: 2

Forum Stats:

Groups: 3

Forums: 14

Topics: 1600

Posts: 5760

Newest Members:

Hema, askask, Rakwireless, budiardi basuki, oliver009, shelby1234

Moderators: cstapels: 460

Administrators: Hans: 405, lee: 457