Ethernet stop responding | Arduino | Forum

Avatar

Please consider registering
Guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Ethernet stop responding
No permission to create posts
December 27, 2011
2:46 am
Avatar
jamilm9
New Member
Members
Forum Posts: 3
Member Since:
December 27, 2011
sp_UserOfflineSmall Offline

Hi, I used the code shown in the tutorial with some small adaptions. These are shown here:

http://pastebin.com/xiGSRkQg  

For some reason it will connect for 15 minutes to one hour and then it will stop connecting. This can be fixed by restarting the arduino by unplugging this. How can this be fixed? Thank you.

December 28, 2011
3:00 am
Avatar
Hans
Natick, MA

Admin
Forum Posts: 396
Member Since:
January 18, 2011
sp_UserOfflineSmall Offline

Are you using Arduino 1.0 or Arduino 22 IDE? This would make a difference in how the Ethernet shield gets restarted. I recommend upgrading to Arduino 1.0 and using our code examples on GitHub.

https://github.com/iobridge/ThingSpeak-Arduino-Examples/blob/master/Ethernet/Arduino_to_ThingSpeak.ino

You would only have to make a few tweaks to get this working in 1.0.

Let us know if you figuring anything out.

December 29, 2011
1:51 am
Avatar
jamilm9
New Member
Members
Forum Posts: 3
Member Since:
December 27, 2011
sp_UserOfflineSmall Offline

I am using 0023. I found a solution to the problem (I think). It's been running for over 24 hours and still going strong. All I had to do was remove the MicroSD card that I had in the slot. For some reason this fixed it. I found this at http://forums.adafruit.com/viewtopic.php?f=31&t=17013

 

Is there any way to convert a float to string? When I convert from a long to a string it is rounded to the nearest whole number. Thanks for all the help.

December 29, 2011
10:52 am
Avatar
Hans
Natick, MA

Admin
Forum Posts: 396
Member Since:
January 18, 2011
sp_UserOfflineSmall Offline

Wow, I am glad that you found that solution. I would have never thought of that. Glad it's working!

December 29, 2011
12:04 pm
Avatar
jamilm9
New Member
Members
Forum Posts: 3
Member Since:
December 27, 2011
sp_UserOfflineSmall Offline

Same. It's strange how these things work. Can you offer any input on converting a float to string? Thanks.

December 29, 2011
9:36 pm
Avatar
Hans
Natick, MA

Admin
Forum Posts: 396
Member Since:
January 18, 2011
sp_UserOfflineSmall Offline

I found a post on the Arduino forum:

#include<stdlib.h>
dtostrf(FLOAT,WIDTH, PRECISION,BUFFER);
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1205038401
(At the bottom of the post, that may help...) 
Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online:
18 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 261

Vinod: 196

piajola: 85

turgo: 70

vespapierre: 63

Adarsh_Murthy: 62

Member Stats:

Guest Posters: 1

Members: 5703

Moderators: 0

Admins: 2

Forum Stats:

Groups: 4

Forums: 17

Topics: 1313

Posts: 4565

Newest Members:

celinabw2, FitoSprayscroma, LunnonGor, lancevl16, bernicenk60, veronicadq18

Administrators: Hans: 387, lee: 457