ThingSpeak to Twilio question | ThingSpeak Apps | Forum

Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_TopicIcon
ThingSpeak to Twilio question
Avatar
russel2512

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
1
October 6, 2015 - 2:01 pm
sp_Permalink sp_Print

I've tried to setup this connection per the tutorial. I'm not having any luck. Can someone step me through the setup with a little more detail.

I'm trying to Use React to send a SMS message through ThingHTTP. I verified that my Twilio account is working correctly. Python script sends a text message to my phone.

Thanks for any help I can get. I need to get this ready for a Hackathon on the 17th.

Russ

Avatar
Hans
Natick, MA

Forum Posts: 390
sp_UserOfflineSmall Offline
2
October 6, 2015 - 3:08 pm
sp_Permalink sp_Print

Russ,

To break down the testing, try to get your ThingHTTP to cause the Twillio SMS to be kicked off. Once you know that works, hook the ThingHTTP up to React.

Twillio might have changed their SMS API since the tutorial was written.

Hans

Avatar
russel2512

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
3
October 6, 2015 - 4:16 pm
sp_Permalink sp_Print

Hans,
That's what I was testing first was the ThingHTTP. I'm using https://api.thingspeak.com/apps/thinghttp/send_request?api_key=xxxxxxxxx to test. Where I'm having problems is Content Type and Body. I'm new to web APIs.

Thanks,
Russ

Avatar
Hans
Natick, MA

Forum Posts: 390
sp_UserOfflineSmall Offline
4
October 6, 2015 - 4:54 pm
sp_Permalink sp_Print sp_EditHistory

From their doc, I see an HTTP POST example.

Content Type: (keep it blank unless you are sending an image)
Body: Use their curl example with each key/value pair separated by an & symbol.

Also, make sure that you are using HTTP auth with ThingHTTP:

Enter your AccountSid under HTTP Auth Username
Enter your Auth Token under HTTP Auth Password

More Twilio API documentation: https://www.twilio.com/docs/api/rest/sending-sms

Avatar
russel2512

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
5
October 7, 2015 - 1:08 pm
sp_Permalink sp_Print

I followed the steps and it's still failing. When I use the above URL with my api key, I get a -1 response code.

If I try https://api.twilio.com/2010-04-01/Accounts/Account Sid/Messages, it prompts me for user ID and password. I enter my Account Sid and Auth Token and the login fails.

I seem to have everything correct, as my Python script works ok.

Russ

Avatar
Hans
Natick, MA

Forum Posts: 390
sp_UserOfflineSmall Offline
6
October 7, 2015 - 1:13 pm
sp_Permalink sp_Print

Russ,

Are you using ThingHTTP?

Hans

Avatar
russel2512

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
7
October 7, 2015 - 1:52 pm
sp_Permalink sp_Print

Yes I am.

Avatar
Hans
Natick, MA

Forum Posts: 390
sp_UserOfflineSmall Offline
8
October 8, 2015 - 11:08 am
sp_Permalink sp_Print

Well, the only way I could help further is to see the exact settings.

What are you sending in each field. Please mask any keys.

Thanks,
Hans

Avatar
russel2512

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
9
October 8, 2015 - 1:46 pm
sp_Permalink sp_Print

API Key: UVQY3NDW3MF6XN1N
URL: https://api.twilio.com/2010-04-01/Accounts/ACverified47f/Messages
HTTP Auth Username: ACverified47f
HTTP Auth Password: 93verifiedf5
Method: POST
Content Type:
HTTP Version: 1.1
Host:
Headers:
Body: From=+1612Twilio #&To=+1verified0&Body=Test
Parse String:

In the setup I copied Username & Password directly from tht Twilio screen.
From number was copied from the screen. To number is validated.

All information works in the Python sample.

Thanks,
Russ

Avatar
russel2512

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
10
October 9, 2015 - 12:04 am
sp_Permalink sp_Print

I got my problem figured out.

https://api.twilio.com/2010-04-01/Accounts/ACverified7f/Messages.json

This URL sent the text.

Russ

Avatar
blackabbys
New Member
Forum Posts: 1
sp_UserOfflineSmall Offline
11
August 22, 2016 - 9:14 pm
sp_Permalink sp_Print

I am having the same problem too. Everything looks fine, I checked everthing thousand times but it still responses me with -1. Lastly I have tried your solution but it is still the same. Please help me how can I solve this problem.

Thank you

Avatar
TomSim
New Member
Forum Posts: 4
sp_UserOfflineSmall Offline
12
August 26, 2016 - 12:29 am
sp_Permalink sp_Print

Use IFTTT Maker URL trigger channel to SMS action.  API key URL style, no authorization needed.

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online:
21 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 252

Vinod: 164

cstapels: 96

piajola: 75

vespapierre: 63

Adarsh_Murthy: 59

Newest Members:

yeseniara11

RomanFug

JamesPes

RobertBak

ScottSmiva

Amourhotte

Forum Stats:

Groups: 4

Forums: 17

Topics: 1313

Posts: 4565

 

Member Stats:

Guest Posters: 1

Members: 5703

Moderators: 0

Admins: 2

Administrators: Hans, lee