Only one, otherwise functional, NodeMCU won't talk to ThingSpeak | ThingSpeak API | Forum

Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_TopicIcon
Only one, otherwise functional, NodeMCU won't talk to ThingSpeak
Avatar
masters42
New Member
Forum Posts: 4
sp_UserOfflineSmall Offline
1
March 22, 2017 - 8:04 pm
sp_Permalink sp_Print

 I'm currently prototyping a device that sends data to ThingSpeak. I've been tinkering on a breadboard, and have a circuit that I like enough that I decided to build it into the hardware of the device so I can test things out off-breadboard.

So I put things into the plastic housing, and soldered everything together-- I know, it's *really* ugly. But all of the solder joints seem just fine, and the whole thing is "clean" insofar as there is no dust, nothing is shorting against anything else, etc.

http://i.imgur.com/yPMED4p.jpg

So here's the thing- I still have my breadboard circuit, and I have a total of 6 NodeMCU's (one purchased as a single, the other in a 5-pack). So I can swap NodeMCU's into and out of the breadboard. The program that I have prints to the serial terminal continuously, and sends data to ThingSpeak once every 20 seconds. 

The code & the breadboard circuit work fine with two different NodeMCU's. I get data both in my serial terminal & on ThingSpeak.

Here's the thing-- I'll put the code onto the NodeMCU built into my device, and everything works except sending data to ThingSpeak. The serial terminal works fine; the sensors are all reading normally. But not a single data point will show up online. I have put in 

int statusCode = ThingSpeak.writeFields(myChannelNumber, myWriteAPIKey);

and I'm getting a -301 error every time-- this is "Failed to connect to ThingSpeak."

Any ideas of what could even cause this problem? 

Avatar
Vinod

Forum Posts: 142
sp_UserOfflineSmall Offline
2
March 22, 2017 - 11:38 pm
sp_Permalink sp_Print

If the circuit works on a breadboard and does not work in the soldered project box, I would wonder if the soldering caused some damage to the WiFi circuit or antenna.

One angle to work is to de-solder the chip from your circuit, put it in to your breadboard and see if it works. Alternatively, try building a circuit with a different nodeMCU chip and see if it works.

Another angle is to see if a simple program can connect to a site like google.com. Something like this:

 

#include <ESP8266WiFi.h>

const char* ssid = "WiFiSSID";
const char* password = "WiFiPassword";

void setup() {
  Serial.begin(115200);
  Serial.println();
  WiFi.begin(ssid, password);
  while (WiFi.status() != WL_CONNECTED) {
    delay(500);
    Serial.print(".");
  }
}

void loop() {
  WiFiClient client;
  while (!client.connect("google.com", 80)) {
    Serial.println("connection failed, retrying...");
  }

  Serial.println("CONNECTED TO GOOGLE");
  delay(5000);
}

 

Now look at the serial monitor. Are ever able to connect to google?

Avatar
JasonW

Forum Posts: 12
sp_UserOfflineSmall Offline
3
March 23, 2017 - 8:38 am
sp_Permalink sp_Print

A long time ago I had a problem similar to this.  My breadboard worked fine but the production unit wouldn't connect.  In my case it was caused by using the same MAC address in both devices while they were both online.  It created chaos in my router as the router didn't know where to send TCP packets.

That probably isn't your problem but make sure your breadboard is offline before powering up the other one, in case they are interfering with each other in some way. 

Avatar
masters42
New Member
Forum Posts: 4
sp_UserOfflineSmall Offline
4
March 23, 2017 - 1:20 pm
sp_Permalink sp_Print

Update: the board in the device wouldn't connect to Google, either-- it just wouldn't connect to the Internet, period. Everything else *appeared* to work just fine- it was connected to an ADC, receiving inputs from 3 different sensors, and serial printing reasonable values. I de-soldered it from everything; still no connection. I removed it from the housing, still no connection.

I soldered together a new circuit fresh, with a different NodeMCU from the same 5-pack. It works 🙂 So that's good. 

Unfortunately, in my initial excitement I can't definitely say that I tested the original board beforehand. I like to *think* that I would have, but I just don't remember. So I don't know if it came unable to connect to WiFi, or if it was some consequence of soldering where the heat fubar'd something.

Also, I noticed that the 5-pack of NodeMCU's I got on Amazon has an odd quirk- the silk screen for the pin labels reads D0 D1 D1 D3 ... as in, pin D2 is mis-labled. It may just be fair to say that I got a bum chip... although it still seems odd to me that the entire SoC works except WiFi. Maybe that makes sense to someone more familiar with how they're put together.

Thanks for the input, folks!

Avatar
brodys
New Member
Forum Posts: 1
sp_UserOfflineSmall Offline
5
September 6, 2017 - 3:57 am
sp_Permalink sp_Print

Same issue here. Thank you for your suggestions!

play bullet force games, router IP address 192.168.0.1 

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online: alexparrado
16 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 250

Vinod: 142

piajola: 73

vespapierre: 63

Adarsh_Murthy: 59

cstapels: 54

Newest Members:

chrissaxon

getty

l3inbin

ossan

gbalychik

wul

Forum Stats:

Groups: 4

Forums: 17

Topics: 1242

Posts: 4315

 

Member Stats:

Guest Posters: 1

Members: 5546

Moderators: 0

Admins: 2

Administrators: Hans, lee