Cannot Add a TalkBack Command via HTTP POST | ThingSpeak API | Forum

Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_TopicIcon
Cannot Add a TalkBack Command via HTTP POST
Avatar
waynebraganza

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
1
January 19, 2015 - 2:31 am
sp_Permalink sp_Print

need help with the add talkback command via http post feature.... im new but i was able to execute the next command via HTTP POST by typing
"https://api.thingspeak.com/talkbacks/1203/commands/execute?api_key=0OT6Y43XC6Y5YVJ9"
in my web browser...

similarly when i tried to add a command by typing
"https://api.thingspeak.com/talkbacks/1203/commands?api_key=0OT6Y43XC6Y5YVJ9&command_string=ON&position=1"
the command was just not getting added.... can any 1 please help....

n sorry if this post is in the wrong part of the forum.... its my first post in a forum.... will appreciate all the help.....
ps. i went through the talk back examples and was able to get the execute next command to work in a few mins.... but the add command part has been haunting me for hours..... i need to use HTTP POSTs in text only as the part of the project... not json and xml

Avatar
lee

Forum Posts: 457
sp_UserOfflineSmall Offline
2
January 19, 2015 - 10:03 am
sp_Permalink sp_Print

Hi,

Executing a TalkBack command is done via HTTP GET or POST, and by typing it into your web browser you are doing an HTTP GET. Adding a command is only allowed via POST though, so typing it into your web browser won't work. To execute a POST you can use an HTML form submit, JavaScript, a browser extension, etc.

lee

Avatar
waynebraganza

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
3
January 20, 2015 - 1:26 am
sp_Permalink sp_Print

oh... .thanks alot man....... that helped... i found an extension for chrome n am able to add commands :) now all i got to do is implement this into an arduino with the esp8566 wifi module....

anyways thanks for d reply... im new to this stuff n ur reply fixed my problems.... :)

Avatar
Midoji
New Member
Forum Posts: 1
sp_UserOfflineSmall Offline
4
March 3, 2016 - 8:58 am
sp_Permalink sp_Print

Hello, what is your google chrome extension for my project ?

Or, do you know any good extension for add command from thingspeak please ? Thanks in advance everyone !

Avatar
waynebraganza

Silver
Forum Posts: 6
sp_UserOfflineSmall Offline
5
December 12, 2017 - 3:36 pm
sp_Permalink sp_Print

Midoji said
Hello, what is your google chrome extension for my project ?

Or, do you know any good extension for add command from thingspeak please ? Thanks in advance everyone !  

hi,

sorry for the really late reply, the extension that i used in chrome is "Chrome Poster"

best of luck with whatever you're doin

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online:
22 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 252

Vinod: 164

cstapels: 96

piajola: 75

vespapierre: 63

Adarsh_Murthy: 59

Newest Members:

dannymm1

KamorkasOr

GRV2903

Jusikaclaiz

Raymondpoers

ScottDus

Forum Stats:

Groups: 4

Forums: 17

Topics: 1313

Posts: 4565

 

Member Stats:

Guest Posters: 1

Members: 5703

Moderators: 0

Admins: 2

Administrators: Hans, lee