Cant send Unsigned long values from arduino to ThingSpeak | Arduino | Forum

Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_TopicIcon
Cant send Unsigned long values from arduino to ThingSpeak
Avatar
rushanarshad

Silver
Forum Posts: 8
sp_UserOfflineSmall Offline
1
July 14, 2017 - 10:56 am
sp_Permalink sp_Print

Hello guys,

I am trying to send my liquid sensor data to ThingSpeak. But, my total liquid variable is unsigned long. The following error comes up in compiling: 

no matching function for call to 'ThingSpeakClass::writeFields(long unsigned int&, int, long unsigned int&, const char*&)'

What could be the reason for this? 

Best Regards

Rushan

Avatar
cstapels

Gold
Forum Posts: 122
sp_UserOnlineSmall Online
2
July 21, 2017 - 4:50 pm
sp_Permalink sp_Print

Can you post the line where you use writeFields?  Possibly you are using the wrong number of arguments or one of the other variables is the wrong type.

Forum Timezone: America/New_York

Most Users Ever Online: 114

Currently Online: cstapels
24 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

rw950431: 252

Vinod: 164

cstapels: 96

piajola: 75

vespapierre: 63

Adarsh_Murthy: 59

Newest Members:

yeseniara11

RomanFug

JamesPes

RobertBak

ScottSmiva

Amourhotte

Forum Stats:

Groups: 4

Forums: 17

Topics: 1313

Posts: 4565

 

Member Stats:

Guest Posters: 1

Members: 5703

Moderators: 0

Admins: 2

Administrators: Hans, lee